summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/libffi/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/libffi/package.py')
-rw-r--r--var/spack/repos/builtin/packages/libffi/package.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/libffi/package.py b/var/spack/repos/builtin/packages/libffi/package.py
index e1c79588ad..ad6a0a8104 100644
--- a/var/spack/repos/builtin/packages/libffi/package.py
+++ b/var/spack/repos/builtin/packages/libffi/package.py
@@ -1,4 +1,4 @@
-# Copyright 2013-2020 Lawrence Livermore National Security, LLC and other
+# Copyright 2013-2021 Lawrence Livermore National Security, LLC and other
# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
# SPDX-License-Identifier: (Apache-2.0 OR MIT)
@@ -32,4 +32,9 @@ class Libffi(AutotoolsPackage, SourcewarePackage):
# Spack adds its own target flags, so tell libffi not to
# second-guess us
args.append('--without-gcc-arch')
+ # At the moment, build scripts accept 'aarch64-apple-darwin'
+ # but not 'arm64-apple-darwin'.
+ # See: https://github.com/libffi/libffi/issues/571
+ if self.spec.satisfies('platform=darwin target=aarch64:'):
+ args.append('--build=aarch64-apple-darwin')
return args