summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/libmolgrid/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/libmolgrid/package.py')
-rw-r--r--var/spack/repos/builtin/packages/libmolgrid/package.py40
1 files changed, 40 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/libmolgrid/package.py b/var/spack/repos/builtin/packages/libmolgrid/package.py
new file mode 100644
index 0000000000..a486a2359a
--- /dev/null
+++ b/var/spack/repos/builtin/packages/libmolgrid/package.py
@@ -0,0 +1,40 @@
+# Copyright 2013-2023 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+import os
+
+from spack.package import *
+
+
+class Libmolgrid(CMakePackage):
+ """libmolgrid is a library to generate tensors from molecular data, with properties
+ that make its output particularly suited to machine learning."""
+
+ homepage = "https://gnina.github.io/libmolgrid/"
+ url = "https://github.com/gnina/libmolgrid/archive/refs/tags/v0.5.2.tar.gz"
+
+ maintainers("RMeli")
+
+ version("0.5.3", sha256="a9f7a62cdeb516bc62a06b324cdd33b095a787df175c6166d74a8d30b6916abb")
+ version("0.5.2", sha256="e732d13a96c2f374d57a73999119bef700172d392c195c751214aa6ac6680c3a")
+
+ depends_on("zlib")
+ depends_on("boost +regex +test +program_options +system +filesystem +iostreams +python")
+ depends_on("openbabel@3:~gui~cairo")
+ depends_on("cuda@11")
+
+ depends_on("python")
+ depends_on("py-numpy")
+ depends_on("py-pytest")
+
+ def cmake_args(self):
+ ob_incl = os.path.join(self.spec["openbabel"].prefix.include, "openbabel3")
+ ob_libs = self.spec["openbabel"].libs.joined(";")
+
+ args = [
+ "-DOPENBABEL3_INCLUDE_DIR=" + ob_incl,
+ "-DOPENBABEL3_LIBRARIES=" + ob_libs,
+ ]
+ return args