summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/libpciaccess/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/libpciaccess/package.py')
-rw-r--r--var/spack/repos/builtin/packages/libpciaccess/package.py13
1 files changed, 13 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/libpciaccess/package.py b/var/spack/repos/builtin/packages/libpciaccess/package.py
index b79e5e9ee7..c82dedf55e 100644
--- a/var/spack/repos/builtin/packages/libpciaccess/package.py
+++ b/var/spack/repos/builtin/packages/libpciaccess/package.py
@@ -20,6 +20,8 @@ class Libpciaccess(AutotoolsPackage, XorgPackage):
depends_on('pkgconfig', type='build')
depends_on('util-macros', type='build')
+ patch('nvhpc.patch', when='%nvhpc')
+
# A known issue exists when building with PGI as documented here:
# https://bugs.freedesktop.org/show_bug.cgi?id=94398
# https://www.pgroup.com/userforum/viewtopic.php?f=4&t=5126
@@ -28,3 +30,14 @@ class Libpciaccess(AutotoolsPackage, XorgPackage):
# When the ability to use dependencies built by another compiler, using a
# libpciaccess built by gcc should be usable by PGI builds.
conflicts('%pgi')
+
+ def configure_args(self):
+ config_args = []
+
+ if (self.spec.satisfies('%nvhpc') and
+ (self.spec.target.family == 'aarch64' or
+ self.spec.target.family == 'ppc64le')):
+ config_args.append('--disable-strict-compilation')
+ config_args.append('--disable-selective-werror')
+
+ return config_args