summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/libpng/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/libpng/package.py')
-rw-r--r--var/spack/repos/builtin/packages/libpng/package.py38
1 files changed, 13 insertions, 25 deletions
diff --git a/var/spack/repos/builtin/packages/libpng/package.py b/var/spack/repos/builtin/packages/libpng/package.py
index a328bd44f8..e9e9d9e56f 100644
--- a/var/spack/repos/builtin/packages/libpng/package.py
+++ b/var/spack/repos/builtin/packages/libpng/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -29,11 +10,13 @@ class Libpng(AutotoolsPackage):
"""libpng is the official PNG reference library."""
homepage = "http://www.libpng.org/pub/png/libpng.html"
- url = "http://download.sourceforge.net/libpng/libpng-1.6.29.tar.gz"
+ url = "http://download.sourceforge.net/libpng/libpng-1.6.34.tar.gz"
list_url = "https://sourceforge.net/projects/libpng/files/"
list_depth = 2
+ version('1.6.34', '03fbc5134830240104e96d3cda648e71')
version('1.6.29', '68553080685f812d1dd7a6b8215c37d8')
+ version('1.6.28', '897ccec1ebfb0922e83c2bfaa1be8748')
version('1.6.27', '58698519e9f6126c1caeefc28dbcbd5f')
# From http://www.libpng.org/pub/png/libpng.html (2017-01-04)
# Virtually all libpng versions through 1.6.26, 1.5.27,
@@ -57,7 +40,12 @@ class Libpng(AutotoolsPackage):
# not honored, see
# https://sourceforge.net/p/libpng/bugs/210/#33f1
# '--with-zlib=' + self.spec['zlib'].prefix,
- 'CFLAGS={0}'.format(self.spec['zlib'].headers.include_flags),
+ 'CPPFLAGS={0}'.format(self.spec['zlib'].headers.include_flags),
'LDFLAGS={0}'.format(self.spec['zlib'].libs.search_flags)
]
return args
+
+ def check(self):
+ # Libpng has both 'check' and 'test' targets that are aliases.
+ # Only need to run the tests once.
+ make('check')