summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/libx11/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/libx11/package.py')
-rw-r--r--var/spack/repos/builtin/packages/libx11/package.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/libx11/package.py b/var/spack/repos/builtin/packages/libx11/package.py
index 924b3c1dbb..fa41e10d74 100644
--- a/var/spack/repos/builtin/packages/libx11/package.py
+++ b/var/spack/repos/builtin/packages/libx11/package.py
@@ -27,6 +27,15 @@ class Libx11(AutotoolsPackage, XorgPackage):
depends_on('util-macros', type='build')
depends_on('perl', type='build')
+ def configure_args(self):
+ config_args = []
+
+ # -Werror flags are not properly interpreted by the NVIDIA compiler
+ if self.spec.satisfies('%nvhpc'):
+ config_args.append('--disable-selective-werror')
+
+ return config_args
+
def setup_dependent_build_environment(self, env, dependent_spec):
env.prepend_path('XLOCALEDIR', self.prefix.share.X11.locale)