summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/libxkbcommon/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/libxkbcommon/package.py')
-rw-r--r--var/spack/repos/builtin/packages/libxkbcommon/package.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/libxkbcommon/package.py b/var/spack/repos/builtin/packages/libxkbcommon/package.py
new file mode 100644
index 0000000000..d864c4b786
--- /dev/null
+++ b/var/spack/repos/builtin/packages/libxkbcommon/package.py
@@ -0,0 +1,32 @@
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class Libxkbcommon(AutotoolsPackage):
+ """xkbcommon is a library to handle keyboard descriptions, including
+ loading them from disk, parsing them and handling their state. It's mainly
+ meant for client toolkits, window systems, and other system
+ applications."""
+
+ homepage = "https://xkbcommon.org/"
+ url = "https://github.com/xkbcommon/libxkbcommon/archive/xkbcommon-0.8.0.tar.gz"
+
+ version('0.8.0', '0d9738fb2ed2dcc6e2c6920d94e135ce')
+
+ depends_on('autoconf', type='build')
+ depends_on('automake', type='build')
+ depends_on('libtool', type='build')
+ depends_on('m4', type='build')
+ depends_on('bison', type='build')
+ depends_on('xkbdata')
+
+ def configure_args(self):
+ spec = self.spec
+ args = []
+ args.append('--with-xkb-config-root={0}'
+ .format(spec['xkbdata'].prefix))
+ return args