summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/libxml2/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/libxml2/package.py')
-rw-r--r--var/spack/repos/builtin/packages/libxml2/package.py37
1 files changed, 12 insertions, 25 deletions
diff --git a/var/spack/repos/builtin/packages/libxml2/package.py b/var/spack/repos/builtin/packages/libxml2/package.py
index 87bbb965b8..eb2409ebf2 100644
--- a/var/spack/repos/builtin/packages/libxml2/package.py
+++ b/var/spack/repos/builtin/packages/libxml2/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -29,9 +10,11 @@ class Libxml2(AutotoolsPackage):
"""Libxml2 is the XML C parser and toolkit developed for the Gnome
project (but usable outside of the Gnome platform), it is free
software available under the MIT License."""
+
homepage = "http://xmlsoft.org"
- url = "http://xmlsoft.org/sources/libxml2-2.9.2.tar.gz"
+ url = "http://xmlsoft.org/sources/libxml2-2.9.8.tar.gz"
+ version('2.9.8', 'b786e353e2aa1b872d70d5d1ca0c740d')
version('2.9.4', 'ae249165c173b1ff386ee8ad676815f5')
version('2.9.2', '9e6a9aca9d155737868b3dc5fd82f788')
version('2.7.8', '8127a65e8c3b08856093099b52599c86')
@@ -44,7 +27,7 @@ class Libxml2(AutotoolsPackage):
depends_on('zlib')
depends_on('xz')
- depends_on('pkg-config@0.9.0:', type='build')
+ depends_on('pkgconfig', type='build')
def configure_args(self):
spec = self.spec
@@ -60,3 +43,7 @@ class Libxml2(AutotoolsPackage):
args.append('--without-python')
return args
+
+ def setup_dependent_environment(self, spack_env, run_env, dependent_spec):
+ spack_env.prepend_path('CPATH', self.prefix.include.libxml2)
+ run_env.prepend_path('CPATH', self.prefix.include.libxml2)