summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/mercurial/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/mercurial/package.py')
-rw-r--r--var/spack/repos/builtin/packages/mercurial/package.py35
1 files changed, 9 insertions, 26 deletions
diff --git a/var/spack/repos/builtin/packages/mercurial/package.py b/var/spack/repos/builtin/packages/mercurial/package.py
index 4ecd3332a9..aaabdd6c01 100644
--- a/var/spack/repos/builtin/packages/mercurial/package.py
+++ b/var/spack/repos/builtin/packages/mercurial/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
from llnl.util import tty
@@ -39,6 +20,7 @@ class Mercurial(PythonPackage):
'mercurial.httpclient', 'mercurial.pure'
]
+ version('4.4.1', '37974a416d1d9525e1375c92025b16d9')
version('4.1.2', '934c99808bdc8385e074b902d59b0d93')
version('3.9.1', '3759dd10edb8c1a6dfb8ff0ce82658ce')
version('3.9', 'e2b355da744e94747daae3a5339d28a0')
@@ -47,7 +29,8 @@ class Mercurial(PythonPackage):
version('3.8.2', 'c38daa0cbe264fc621dc3bb05933b0b3')
version('3.8.1', '172a8c588adca12308c2aca16608d7f4')
- depends_on('python@2.6:2.8')
+ depends_on('python@2.6:2.8', when='@:4.2.99')
+ depends_on('python@2.7:2.8,3.5:3.5.999,3.6.2:', when='@4.3:')
depends_on('py-docutils', type='build')
depends_on('py-pygments', type=('build', 'run'))
depends_on('py-certifi', type=('build', 'run'))
@@ -84,8 +67,8 @@ class Mercurial(PythonPackage):
hgrc_filename = join_path(etc_dir, 'hgrc')
# Use certifi to find the location of the CA certificate
- certificate = python('-c', 'import certifi; print certifi.where()',
- output=str)
+ print_str = self.spec['python'].package.print_string('certifi.where()')
+ certificate = python('-c', 'import certifi; ' + print_str)
if not certificate:
tty.warn('CA certificate not found. You may not be able to '