summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/minizip/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/minizip/package.py')
-rw-r--r--var/spack/repos/builtin/packages/minizip/package.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/minizip/package.py b/var/spack/repos/builtin/packages/minizip/package.py
index 0bf524da48..2871582295 100644
--- a/var/spack/repos/builtin/packages/minizip/package.py
+++ b/var/spack/repos/builtin/packages/minizip/package.py
@@ -1,4 +1,4 @@
-# Copyright 2013-2020 Lawrence Livermore National Security, LLC and other
+# Copyright 2013-2021 Lawrence Livermore National Security, LLC and other
# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
# SPDX-License-Identifier: (Apache-2.0 OR MIT)
@@ -22,6 +22,14 @@ class Minizip(AutotoolsPackage):
depends_on('m4', type='build')
depends_on('zlib')
+ # error: implicit declaration of function 'mkdir' is invalid in C99
+ patch('implicit.patch', when='%apple-clang@12:')
+ patch('implicit.patch', when='%gcc@7.3.0:')
+
+ # statically link to libz.a
+ # https://github.com/Homebrew/homebrew-core/blob/master/Formula/minizip.rb
+ patch('static.patch', when='%apple-clang@12:')
+
# build minizip and miniunz
@run_before('autoreconf')
def build_minizip_binary(self):