summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/mpileaks/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/mpileaks/package.py')
-rw-r--r--var/spack/repos/builtin/packages/mpileaks/package.py34
1 files changed, 20 insertions, 14 deletions
diff --git a/var/spack/repos/builtin/packages/mpileaks/package.py b/var/spack/repos/builtin/packages/mpileaks/package.py
index ce0081fc7f..38a6cdd5ed 100644
--- a/var/spack/repos/builtin/packages/mpileaks/package.py
+++ b/var/spack/repos/builtin/packages/mpileaks/package.py
@@ -11,29 +11,35 @@ class Mpileaks(AutotoolsPackage):
MPI_Datatypes."""
homepage = "https://github.com/LLNL/mpileaks"
- url = "https://github.com/LLNL/mpileaks/releases/download/v1.0/mpileaks-1.0.tar.gz"
+ url = "https://github.com/LLNL/mpileaks/releases/download/v1.0/mpileaks-1.0.tar.gz"
- version('1.0', sha256='2e34cc4505556d1c1f085758e26f2f8eea0972db9382f051b2dcfb1d7d9e1825')
+ version("1.0", sha256="2e34cc4505556d1c1f085758e26f2f8eea0972db9382f051b2dcfb1d7d9e1825")
- variant('stackstart', values=int, default=0,
- description='Specify the number of stack frames to truncate')
+ variant(
+ "stackstart",
+ values=int,
+ default=0,
+ description="Specify the number of stack frames to truncate",
+ )
- depends_on('mpi')
- depends_on('adept-utils')
- depends_on('callpath')
+ depends_on("mpi")
+ depends_on("adept-utils")
+ depends_on("callpath")
def configure_args(self):
- stackstart = int(self.spec.variants['stackstart'].value)
+ stackstart = int(self.spec.variants["stackstart"].value)
args = [
- '--with-adept-utils={0}'.format(self.spec['adept-utils'].prefix),
- '--with-callpath={0}'.format(self.spec['callpath'].prefix),
+ "--with-adept-utils={0}".format(self.spec["adept-utils"].prefix),
+ "--with-callpath={0}".format(self.spec["callpath"].prefix),
]
if stackstart:
- args.extend([
- '--with-stack-start-c={0}'.format(stackstart),
- '--with-stack-start-fortran={0}'.format(stackstart)
- ])
+ args.extend(
+ [
+ "--with-stack-start-c={0}".format(stackstart),
+ "--with-stack-start-fortran={0}".format(stackstart),
+ ]
+ )
return args