summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/mxm/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/mxm/package.py')
-rw-r--r--var/spack/repos/builtin/packages/mxm/package.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/mxm/package.py b/var/spack/repos/builtin/packages/mxm/package.py
new file mode 100644
index 0000000000..897f1c24b3
--- /dev/null
+++ b/var/spack/repos/builtin/packages/mxm/package.py
@@ -0,0 +1,30 @@
+# Copyright 2013-2020 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class Mxm(Package):
+ """Mellanox Messaging Accelerator (MXM) provides enhancements to parallel
+ communication libraries by fully utilizing the underlying networking
+ infrastructure provided by Mellanox HCA/switch hardware."""
+
+ homepage = 'https://www.mellanox.com/products/mxm'
+ has_code = False
+
+ version('3.6.3104')
+
+ # MXM needs to be added as an external package to SPACK. For this, the
+ # config file packages.yaml needs to be adjusted:
+ # mxm:
+ # version: [3.6.3104]
+ # paths:
+ # mxm@3.6.3104: /opt/mellanox/mxm (path to your MXM installation)
+ # buildable: False
+
+ def install(self, spec, prefix):
+ raise InstallError(
+ self.spec.format('{name} is not installable, you need to specify '
+ 'it as an external package in packages.yaml'))