summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/nco/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/nco/package.py')
-rw-r--r--var/spack/repos/builtin/packages/nco/package.py34
1 files changed, 11 insertions, 23 deletions
diff --git a/var/spack/repos/builtin/packages/nco/package.py b/var/spack/repos/builtin/packages/nco/package.py
index 2aea5aed2c..6b46596b6e 100644
--- a/var/spack/repos/builtin/packages/nco/package.py
+++ b/var/spack/repos/builtin/packages/nco/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -60,3 +41,10 @@ class Nco(AutotoolsPackage):
def configure_args(self):
spec = self.spec
return ['--{0}-doc'.format('enable' if '+doc' in spec else 'disable')]
+
+ def setup_environment(self, spack_env, run_env):
+ spec = self.spec
+ spack_env.set('NETCDF_INC', spec['netcdf'].prefix.include)
+ spack_env.set('NETCDF_LIB', spec['netcdf'].prefix.lib)
+ spack_env.set('ANTLR_ROOT', spec['antlr'].prefix)
+ spack_env.set('UDUNITS2_PATH', spec['udunits2'].prefix)