summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/netcdf-fortran/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/netcdf-fortran/package.py')
-rw-r--r--var/spack/repos/builtin/packages/netcdf-fortran/package.py36
1 files changed, 12 insertions, 24 deletions
diff --git a/var/spack/repos/builtin/packages/netcdf-fortran/package.py b/var/spack/repos/builtin/packages/netcdf-fortran/package.py
index f62db6eca0..64d4eca2a0 100644
--- a/var/spack/repos/builtin/packages/netcdf-fortran/package.py
+++ b/var/spack/repos/builtin/packages/netcdf-fortran/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -36,6 +17,13 @@ class NetcdfFortran(AutotoolsPackage):
depends_on('netcdf')
+ # The default libtool.m4 is too old to handle NAG compiler properly:
+ # https://github.com/Unidata/netcdf-fortran/issues/94
+ patch('nag.patch', when='@:4.4.4%nag')
+
+ def configure_args(self):
+ return ['CPPFLAGS=-I' + self.spec['netcdf'].prefix.include]
+
@property
def libs(self):
libraries = ['libnetcdff']
@@ -46,5 +34,5 @@ class NetcdfFortran(AutotoolsPackage):
shared = 'shared' in query_parameters
return find_libraries(
- libraries, root=self.prefix, shared=shared, recurse=True
+ libraries, root=self.prefix, shared=shared, recursive=True
)