summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/nlopt/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/nlopt/package.py')
-rw-r--r--var/spack/repos/builtin/packages/nlopt/package.py62
1 files changed, 62 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/nlopt/package.py b/var/spack/repos/builtin/packages/nlopt/package.py
new file mode 100644
index 0000000000..c1c69cba01
--- /dev/null
+++ b/var/spack/repos/builtin/packages/nlopt/package.py
@@ -0,0 +1,62 @@
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class Nlopt(CMakePackage):
+ """NLopt is a free/open-source library for nonlinear optimization,
+ providing a common interface for a number of different free optimization
+ routines available online as well as original implementations of various
+ other algorithms."""
+
+ homepage = "https://nlopt.readthedocs.io"
+ url = "https://github.com/stevengj/nlopt/archive/v2.5.0.tar.gz"
+ git = "https://github.com/stevengj/nlopt.git"
+
+ version('develop', branch='master')
+ version('2.5.0', 'ada08c648bf9b52faf8729412ff6dd6d')
+
+ variant('shared', default=True, description='Enables the build of shared libraries')
+ variant('python', default=True, description='Build python wrappers')
+ variant('guile', default=False, description='Enable Guile support')
+ variant('octave', default=False, description='Enable GNU Octave support')
+ variant('cxx', default=False, description='Build the C++ routines')
+
+ # Note: matlab is licenced - spack does not download automatically
+ variant("matlab", default=False, description="Build the Matlab bindings.")
+
+ depends_on('cmake@3.0:', type='build', when='@develop')
+ depends_on('python', when='+python')
+ depends_on('py-numpy', when='+python', type=('build', 'run'))
+ depends_on('swig', when='+python')
+ depends_on('guile', when='+guile')
+ depends_on('octave', when='+octave')
+ depends_on('matlab', when='+matlab')
+
+ def cmake_args(self):
+ # Add arguments other than
+ # CMAKE_INSTALL_PREFIX and CMAKE_BUILD_TYPE
+ spec = self.spec
+ args = []
+
+ # Specify on command line to alter defaults:
+ # eg: spack install nlopt@develop +guile -octave +cxx
+
+ # Spack should locate python by default - but to point to a build
+ if '+python' in spec:
+ args.append("-DPYTHON_EXECUTABLE=%s" % spec['python'].command.path)
+
+ # On is default
+ if '-shared' in spec:
+ args.append('-DBUILD_SHARED_LIBS:Bool=OFF')
+
+ if '+cxx' in spec:
+ args.append('-DNLOPT_CXX:BOOL=ON')
+
+ if '+matlab' in spec:
+ args.append("-DMatlab_ROOT_DIR=%s" % spec['matlab'].command.path)
+
+ return args