summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/openmpi/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/openmpi/package.py')
-rw-r--r--var/spack/repos/builtin/packages/openmpi/package.py22
1 files changed, 16 insertions, 6 deletions
diff --git a/var/spack/repos/builtin/packages/openmpi/package.py b/var/spack/repos/builtin/packages/openmpi/package.py
index b0efe27def..67bf6f3713 100644
--- a/var/spack/repos/builtin/packages/openmpi/package.py
+++ b/var/spack/repos/builtin/packages/openmpi/package.py
@@ -50,12 +50,14 @@ def _verbs_dir():
class Openmpi(Package):
- """Open MPI is a project combining technologies and resources from
- several other projects (FT-MPI, LA-MPI, LAM/MPI, and PACX-MPI)
- in order to build the best MPI library available. A completely
- new MPI-2 compliant implementation, Open MPI offers advantages
- for system and software vendors, application developers and
- computer science researchers.
+ """The Open MPI Project is an open source Message Passing Interface
+ implementation that is developed and maintained by a consortium
+ of academic, research, and industry partners. Open MPI is
+ therefore able to combine the expertise, technologies, and
+ resources from all across the High Performance Computing
+ community in order to build the best MPI library available.
+ Open MPI offers advantages for system and software vendors,
+ application developers and computer science researchers.
"""
homepage = "http://www.open-mpi.org"
@@ -127,6 +129,10 @@ class Openmpi(Package):
self.spec.mpicxx = join_path(self.prefix.bin, 'mpic++')
self.spec.mpifc = join_path(self.prefix.bin, 'mpif90')
self.spec.mpif77 = join_path(self.prefix.bin, 'mpif77')
+ self.spec.mpicxx_shared_libs = [
+ join_path(self.prefix.lib, 'libmpi_cxx.{0}'.format(dso_suffix)),
+ join_path(self.prefix.lib, 'libmpi.{0}'.format(dso_suffix))
+ ]
def setup_environment(self, spack_env, run_env):
# As of 06/2016 there is no mechanism to specify that packages which
@@ -159,6 +165,10 @@ class Openmpi(Package):
"--enable-shared",
"--enable-static"]
+ # for Open-MPI 2.0:, C++ bindings are disabled by default.
+ if self.spec.satisfies('@2.0:'):
+ config_args.extend(['--enable-mpi-cxx'])
+
if getattr(self, 'config_extra', None) is not None:
config_args.extend(self.config_extra)