summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/p4est/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/p4est/package.py')
-rw-r--r--var/spack/repos/builtin/packages/p4est/package.py27
1 files changed, 19 insertions, 8 deletions
diff --git a/var/spack/repos/builtin/packages/p4est/package.py b/var/spack/repos/builtin/packages/p4est/package.py
index 1e2969fe64..adf75babb9 100644
--- a/var/spack/repos/builtin/packages/p4est/package.py
+++ b/var/spack/repos/builtin/packages/p4est/package.py
@@ -7,10 +7,17 @@ class P4est(Package):
version('1.1', '37ba7f4410958cfb38a2140339dbf64f')
- # disable by default to make it work on frontend of clusters
- variant('tests', default=False, description='Run small tests')
+ variant('tests', default=True, description='Run small tests')
+ # build dependencies
+ depends_on('automake')
+ depends_on('autoconf')
+ depends_on('libtool@2.4.2:')
+
+ # other dependencies
+ depends_on('lua') # Needed for the submodule sc
depends_on('mpi')
+ depends_on('zlib')
def install(self, spec, prefix):
options = ['--enable-mpi',
@@ -19,16 +26,20 @@ class P4est(Package):
'--without-blas',
'CPPFLAGS=-DSC_LOG_PRIORITY=SC_LP_ESSENTIAL',
'CFLAGS=-O2',
- 'CC=%s' % join_path(self.spec['mpi'].prefix.bin, 'mpicc'), # TODO: use ENV variables or MPI class wrappers
- 'CXX=%s' % join_path(self.spec['mpi'].prefix.bin, 'mpic++'),
- 'FC=%s' % join_path(self.spec['mpi'].prefix.bin, 'mpif90'),
- 'F77=%s' % join_path(self.spec['mpi'].prefix.bin, 'mpif77'),
+ 'CC=%s' % self.spec['mpi'].mpicc,
+ 'CXX=%s' % self.spec['mpi'].mpicxx,
+ 'FC=%s' % self.spec['mpi'].mpifc,
+ 'F77=%s' % self.spec['mpi'].mpif77
]
configure('--prefix=%s' % prefix, *options)
make()
+ # Make tests optional as sometimes mpiexec can't be run with an error:
+ # mpiexec has detected an attempt to run as root.
+ # Running at root is *strongly* discouraged as any mistake (e.g., in
+ # defining TMPDIR) or bug can result in catastrophic damage to the OS
+ # file system, leaving your system in an unusable state.
if '+tests' in self.spec:
- make("check")
-
+ make("check")
make("install")