summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/perl/nvhpc-5.34.patch
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/perl/nvhpc-5.34.patch')
-rw-r--r--var/spack/repos/builtin/packages/perl/nvhpc-5.34.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/perl/nvhpc-5.34.patch b/var/spack/repos/builtin/packages/perl/nvhpc-5.34.patch
new file mode 100644
index 0000000000..18b18b2e64
--- /dev/null
+++ b/var/spack/repos/builtin/packages/perl/nvhpc-5.34.patch
@@ -0,0 +1,42 @@
+--- a/Configure
++++ b/Configure
+@@ -4862,7 +4862,7 @@
+ # and usrinc directly from the compiler.
+ # Note that ccname for clang is also gcc.
+ case "$ccname" in
+- gcc)
++ XXX)
+ realpath=`which realpath 2>/dev/null | sed 's/no realpath in.*//'`
+ $echo 'extern int foo;' > try.c
+ set X `$cppstdin -v try.c 2>&1 | $awk '/^#include </,/^End of search /'|$cppfilter $grep '/include'`
+--- a/Makefile.SH
++++ b/Makefile.SH
+@@ -1143,7 +1143,7 @@
+ # But also this ensures that all extensions are built before we try to scan
+ # them, which picks up Devel::PPPort's documentation.
+ pod/perltoc.pod: $(perltoc_pod_prereqs) $(PERL_EXE) $(ext) pod/buildtoc
+- $(RUN_PERL) -f pod/buildtoc -q
++ $(MINIPERL) -f pod/buildtoc -q
+
+ pod/perlapi.pod: pod/perlintern.pod
+
+@@ -1200,8 +1200,8 @@
+ $spitshell >>$Makefile <<EOT
+
+ install_$name install-$name: \$(INSTALL_DEPENDENCE) installperl all installman
+- \$(RUN_PERL) installperl --destdir=\$(DESTDIR) $flags \$(INSTALLFLAGS) \$(STRIPFLAGS)
+- \$(RUN_PERL) installman --destdir=\$(DESTDIR) $flags
++ \$(MINIPERL) installperl --destdir=\$(DESTDIR) $flags \$(INSTALLFLAGS) \$(STRIPFLAGS)
++ \$(MINIPERL) installman --destdir=\$(DESTDIR) $flags
+ EOT
+ fi
+
+@@ -1219,7 +1219,7 @@
+ LOCAL_PERL='$(RUN_PERL)'
+ $spitshell >>$Makefile <<'!NO!SUBS!'
+ install.perl: $(INSTALL_DEPENDENCE) installperl
+- $(RUN_PERL) installperl --destdir=$(DESTDIR) $(INSTALLFLAGS) $(STRIPFLAGS)
++ $(MINIPERL) installperl --destdir=$(DESTDIR) $(INSTALLFLAGS) $(STRIPFLAGS)
+ -@test ! -s extras.lst || PATH="`pwd`:\${PATH}" PERL5LIB="`pwd`/lib" \$(RUN_PERL) -Ilib -MCPAN -e '@ARGV&&install(@ARGV)' `cat extras.lst`
+
+ !NO!SUBS!