summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/pflotran/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/pflotran/package.py')
-rw-r--r--var/spack/repos/builtin/packages/pflotran/package.py40
1 files changed, 13 insertions, 27 deletions
diff --git a/var/spack/repos/builtin/packages/pflotran/package.py b/var/spack/repos/builtin/packages/pflotran/package.py
index e04e33a1db..73f95f75f7 100644
--- a/var/spack/repos/builtin/packages/pflotran/package.py
+++ b/var/spack/repos/builtin/packages/pflotran/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -32,13 +13,18 @@ class Pflotran(AutotoolsPackage):
"""
homepage = "http://www.pflotran.org"
+ git = "https://bitbucket.org/pflotran/pflotran.git"
- version('develop', git='https://bitbucket.org/pflotran/pflotran')
- version('xsdk-0.2.0', git='https://bitbucket.org/pflotran/pflotran', tag='master')
+ version('develop')
+ version('xsdk-0.2.0', tag='master')
+ version('xsdk-0.3.0', branch='release/xsdk-0.3.0')
depends_on('mpi')
depends_on('hdf5@1.8.12:+mpi+fortran')
depends_on('petsc@develop+hdf5+metis', when='@develop')
- depends_on('petsc@xsdk-0.2.0+hdf5+metis', when='@xsdk-0.2.0')
+ depends_on('petsc@xsdk-0.2.0+hdf5+metis', when='@xsdk-0.2.0')
+ depends_on('petsc@3.8.0:+hdf5+metis', when='@xsdk-0.3.0')
- parallel = False
+ @property
+ def parallel(self):
+ return self.spec.satisfies('@develop')