summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/photos-f/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/photos-f/package.py')
-rw-r--r--var/spack/repos/builtin/packages/photos-f/package.py24
1 files changed, 13 insertions, 11 deletions
diff --git a/var/spack/repos/builtin/packages/photos-f/package.py b/var/spack/repos/builtin/packages/photos-f/package.py
index e8db4d0b2e..6bd2fbf4cb 100644
--- a/var/spack/repos/builtin/packages/photos-f/package.py
+++ b/var/spack/repos/builtin/packages/photos-f/package.py
@@ -14,13 +14,15 @@ class PhotosF(MakefilePackage):
"""PHOTOS Monte-Carlo generator (Fortran version)"""
homepage = "https://wasm.web.cern.ch/wasm/f77.html"
- url = "http://cern.ch/service-spi/external/MCGenerators/distribution/photos/photos-215.5-src.tgz"
+ url = (
+ "http://cern.ch/service-spi/external/MCGenerators/distribution/photos/photos-215.5-src.tgz"
+ )
- maintainers = ['iarspider']
+ maintainers = ["iarspider"]
- version('215.5', sha256='3e2b3f60ffe2d3a6a95cf2f156aa24b93e1fa3c439a85fa0ae780ca2f6e0dbb5')
+ version("215.5", sha256="3e2b3f60ffe2d3a6a95cf2f156aa24b93e1fa3c439a85fa0ae780ca2f6e0dbb5")
- patch('photos-215.5-update-configure.patch', level=2)
+ patch("photos-215.5-update-configure.patch", level=2)
def do_stage(self, mirror_only=False):
# Fix directory structure - remove extra "<version>" subdirectory
@@ -31,14 +33,14 @@ class PhotosF(MakefilePackage):
shutil.rmtree(root)
def edit(self, spec, prefix):
- configure_ = Executable('./configure')
- configure_('--enable-static', '--disable-shared')
- if self.spec.satisfies('platform=darwin'):
- filter_file('libphotos.so', 'libphotos.dylib', 'Makefile')
+ configure_ = Executable("./configure")
+ configure_("--enable-static", "--disable-shared")
+ if self.spec.satisfies("platform=darwin"):
+ filter_file("libphotos.so", "libphotos.dylib", "Makefile")
def install(self, spec, prefix):
- install_tree('lib', prefix.lib)
- install_tree('include', prefix.include)
- for fn in glob(join_path(prefix.lib.archive, '*.a')):
+ install_tree("lib", prefix.lib)
+ install_tree("include", prefix.include)
+ for fn in glob(join_path(prefix.lib.archive, "*.a")):
install(fn, prefix.lib)
shutil.rmtree(prefix.lib.archive)