summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/pkg-config/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/pkg-config/package.py')
-rw-r--r--var/spack/repos/builtin/packages/pkg-config/package.py39
1 files changed, 7 insertions, 32 deletions
diff --git a/var/spack/repos/builtin/packages/pkg-config/package.py b/var/spack/repos/builtin/packages/pkg-config/package.py
index 22a8833a11..a27df03b40 100644
--- a/var/spack/repos/builtin/packages/pkg-config/package.py
+++ b/var/spack/repos/builtin/packages/pkg-config/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -36,6 +17,8 @@ class PkgConfig(AutotoolsPackage):
version('0.29.1', 'f739a28cae4e0ca291f82d1d41ef107d')
version('0.28', 'aa3c86e67551adc3ac865160e34a2a0d')
+ provides('pkgconfig')
+
variant('internal_glib', default=True,
description='Builds with internal glib')
@@ -45,17 +28,9 @@ class PkgConfig(AutotoolsPackage):
parallel = False
def setup_dependent_environment(self, spack_env, run_env, dependent_spec):
- """spack built pkg-config on cray's requires adding /usr/local/
- and /usr/lib64/ to PKG_CONFIG_PATH in order to access cray '.pc'
- files.
- Adds the ACLOCAL path for autotools."""
+ """Adds the ACLOCAL path for autotools."""
spack_env.append_path('ACLOCAL_PATH',
join_path(self.prefix.share, 'aclocal'))
- if 'platform=cray' in self.spec:
- spack_env.append_path('PKG_CONFIG_PATH',
- '/usr/lib64/pkgconfig')
- spack_env.append_path('PKG_CONFIG_PATH',
- '/usr/local/lib64/pkgconfig')
def configure_args(self):
config_args = ['--enable-shared']