summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-csvkit/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-csvkit/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-csvkit/package.py38
1 files changed, 19 insertions, 19 deletions
diff --git a/var/spack/repos/builtin/packages/py-csvkit/package.py b/var/spack/repos/builtin/packages/py-csvkit/package.py
index 903c38ba75..99335a67d5 100644
--- a/var/spack/repos/builtin/packages/py-csvkit/package.py
+++ b/var/spack/repos/builtin/packages/py-csvkit/package.py
@@ -10,28 +10,28 @@ class PyCsvkit(PythonPackage):
"""A library of utilities for working with CSV, the king of tabular file
formats"""
- homepage = 'http://csvkit.rtfd.org/'
+ homepage = "http://csvkit.rtfd.org/"
pypi = "csvkit/csvkit-0.9.1.tar.gz"
- version('1.0.4', sha256='1353a383531bee191820edfb88418c13dfe1cdfa9dd3dc46f431c05cd2a260a0')
- version('0.9.1', sha256='92f8b8647becb5cb1dccb3af92a13a4e85702d42ba465ce8447881fb38c9f93a')
+ version("1.0.4", sha256="1353a383531bee191820edfb88418c13dfe1cdfa9dd3dc46f431c05cd2a260a0")
+ version("0.9.1", sha256="92f8b8647becb5cb1dccb3af92a13a4e85702d42ba465ce8447881fb38c9f93a")
- depends_on('py-setuptools', type=('build', 'run'))
- depends_on('py-six@1.6.1:', type=('build', 'run'))
- depends_on('py-argparse@1.2.1:', type=('build', 'run'), when='^python@:2.6,3.0:3.1')
- depends_on('py-ordereddict@1.1:', type=('build', 'run'), when='^python@:2.6')
- depends_on('py-simplejson@3.6.3:', type=('build', 'run'), when='^python@:2.6')
- depends_on('py-python-dateutil@2.2', type=('build', 'run'), when='@0.9.1')
- depends_on('py-dbf@0.94.003', type=('build', 'run'), when='@0.9.1')
- depends_on('py-xlrd@0.7.1:', type=('build', 'run'), when='@0.9.1')
- depends_on('py-sqlalchemy@0.6.6:', type=('build', 'run'), when='@0.9.1')
- depends_on('py-openpyxl@2.2.0', type=('build', 'run'), when='@0.9.1')
- depends_on('py-agate@1.6.1:', type=('build', 'run'), when='@1:')
- depends_on('py-agate-excel@0.2.2:', type=('build', 'run'), when='@1:')
- depends_on('py-agate-dbf@0.2.0:', type=('build', 'run'), when='@1:')
- depends_on('py-agate-sql@0.5.3:', type=('build', 'run'), when='@1:')
+ depends_on("py-setuptools", type=("build", "run"))
+ depends_on("py-six@1.6.1:", type=("build", "run"))
+ depends_on("py-argparse@1.2.1:", type=("build", "run"), when="^python@:2.6,3.0:3.1")
+ depends_on("py-ordereddict@1.1:", type=("build", "run"), when="^python@:2.6")
+ depends_on("py-simplejson@3.6.3:", type=("build", "run"), when="^python@:2.6")
+ depends_on("py-python-dateutil@2.2", type=("build", "run"), when="@0.9.1")
+ depends_on("py-dbf@0.94.003", type=("build", "run"), when="@0.9.1")
+ depends_on("py-xlrd@0.7.1:", type=("build", "run"), when="@0.9.1")
+ depends_on("py-sqlalchemy@0.6.6:", type=("build", "run"), when="@0.9.1")
+ depends_on("py-openpyxl@2.2.0", type=("build", "run"), when="@0.9.1")
+ depends_on("py-agate@1.6.1:", type=("build", "run"), when="@1:")
+ depends_on("py-agate-excel@0.2.2:", type=("build", "run"), when="@1:")
+ depends_on("py-agate-dbf@0.2.0:", type=("build", "run"), when="@1:")
+ depends_on("py-agate-sql@0.5.3:", type=("build", "run"), when="@1:")
- @when('@0.9.1')
+ @when("@0.9.1")
def patch(self):
# Non-existent version requirement
- filter_file('2.2.0-b1', '2.2.0', 'setup.py', string=True)
+ filter_file("2.2.0-b1", "2.2.0", "setup.py", string=True)