summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-epydoc/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-epydoc/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-epydoc/package.py13
1 files changed, 13 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-epydoc/package.py b/var/spack/repos/builtin/packages/py-epydoc/package.py
new file mode 100644
index 0000000000..af05510504
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-epydoc/package.py
@@ -0,0 +1,13 @@
+from spack import *
+
+class PyEpydoc(Package):
+ """Epydoc is a tool for generating API documentation documentation for Python modules, based on their docstrings."""
+ homepage = "https://pypi.python.org/pypi/epydoc"
+ url = "https://pypi.python.org/packages/source/e/epydoc/epydoc-3.0.1.tar.gz"
+
+ version('3.0.1', '36407974bd5da2af00bf90ca27feeb44')
+
+ extends('python')
+
+ def install(self, spec, prefix):
+ python('setup.py', 'install', '--prefix=%s' % prefix)