summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-git-review/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-git-review/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-git-review/package.py30
1 files changed, 6 insertions, 24 deletions
diff --git a/var/spack/repos/builtin/packages/py-git-review/package.py b/var/spack/repos/builtin/packages/py-git-review/package.py
index 596f8016aa..60291f5b1a 100644
--- a/var/spack/repos/builtin/packages/py-git-review/package.py
+++ b/var/spack/repos/builtin/packages/py-git-review/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -31,6 +12,7 @@ class PyGitReview(PythonPackage):
homepage = "http://docs.openstack.org/infra/git-review"
url = "https://pypi.io/packages/source/g/git-review/git-review-1.25.0.tar.gz"
+ version('1.26.0', 'dec20e8a259c03fe19c9dd2362c4ec3f')
version('1.25.0', '0a061d0e23ee9b93c6212a3fe68fb7ab')
version('1.24', '145116fe58a3487c3ad1bf55538fd741')
version('1.23', 'b0023ad8c037ab710da81412194c6a3a')
@@ -46,4 +28,4 @@ class PyGitReview(PythonPackage):
depends_on('tk', type=('run'))
def setup_environment(self, spack_env, run_env):
- run_env.set('PBR_VERSION', self.spec.version)
+ run_env.set('PBR_VERSION', str(self.spec.version))