summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-gnuplot/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-gnuplot/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-gnuplot/package.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-gnuplot/package.py b/var/spack/repos/builtin/packages/py-gnuplot/package.py
new file mode 100644
index 0000000000..ede4472c03
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-gnuplot/package.py
@@ -0,0 +1,14 @@
+from spack import *
+
+class PyGnuplot(Package):
+ """Gnuplot.py is a Python package that allows you to create graphs from within Python using the gnuplot plotting program."""
+ homepage = "http://gnuplot-py.sourceforge.net/"
+ url = "http://downloads.sourceforge.net/project/gnuplot-py/Gnuplot-py/1.8/gnuplot-py-1.8.tar.gz"
+
+ version('1.8', 'abd6f571e7aec68ae7db90a5217cd5b1')
+
+ extends('python')
+ depends_on('py-numpy')
+
+ def install(self, spec, prefix):
+ python('setup.py', 'install', '--prefix=%s' % prefix)