summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-ipykernel/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-ipykernel/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-ipykernel/package.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/var/spack/repos/builtin/packages/py-ipykernel/package.py b/var/spack/repos/builtin/packages/py-ipykernel/package.py
index 3d2fbfd5a1..fb8a9978ec 100644
--- a/var/spack/repos/builtin/packages/py-ipykernel/package.py
+++ b/var/spack/repos/builtin/packages/py-ipykernel/package.py
@@ -55,9 +55,8 @@ class PyIpykernel(PythonPackage):
depends_on('py-matplotlib-inline@0.1.0:0.1', when='@6:', type=('build', 'run'))
depends_on('py-appnope', when='platform=darwin', type=('build', 'run'))
- phases = ['build', 'install', 'install_data']
-
- def install_data(self, spec, prefix):
+ @run_after('install')
+ def install_data(self):
""" install the Jupyter kernel spec """
self.spec['python'].command(
- '-m', 'ipykernel', 'install', '--prefix=' + prefix)
+ '-m', 'ipykernel', 'install', '--prefix=' + self.prefix)