summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-line-profiler/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-line-profiler/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-line-profiler/package.py20
1 files changed, 10 insertions, 10 deletions
diff --git a/var/spack/repos/builtin/packages/py-line-profiler/package.py b/var/spack/repos/builtin/packages/py-line-profiler/package.py
index 1860265d9f..72a561fead 100644
--- a/var/spack/repos/builtin/packages/py-line-profiler/package.py
+++ b/var/spack/repos/builtin/packages/py-line-profiler/package.py
@@ -14,23 +14,23 @@ class PyLineProfiler(PythonPackage):
homepage = "https://github.com/rkern/line_profiler"
pypi = "line_profiler/line_profiler-2.0.tar.gz"
- version('2.1.2', sha256='efa66e9e3045aa7cb1dd4bf0106e07dec9f80bc781a993fbaf8162a36c20af5c')
- version('2.0', sha256='739f8ad0e4bcd0cb82e99afc09e00a0351234f6b3f0b1f7f0090a8a2fbbf8381')
+ version("2.1.2", sha256="efa66e9e3045aa7cb1dd4bf0106e07dec9f80bc781a993fbaf8162a36c20af5c")
+ version("2.0", sha256="739f8ad0e4bcd0cb82e99afc09e00a0351234f6b3f0b1f7f0090a8a2fbbf8381")
- depends_on('python@2.5:', type=('build', 'run'))
- depends_on('py-setuptools', type='build')
- depends_on('py-cython', type='build')
- depends_on('py-ipython@0.13:', type=('build', 'run'))
+ depends_on("python@2.5:", type=("build", "run"))
+ depends_on("py-setuptools", type="build")
+ depends_on("py-cython", type="build")
+ depends_on("py-ipython@0.13:", type=("build", "run"))
# See https://github.com/rkern/line_profiler/issues/166
- @run_before('install')
+ @run_before("install")
def fix_cython(self):
# TODO: Replace the check with a `@when('^python@3.7:')` decorator once
# https://github.com/spack/spack/issues/12736 is resolved
if not self.spec.satisfies("^python@3.7:"):
return
- cython = self.spec['py-cython'].command
- for root, _, files in os.walk('.'):
+ cython = self.spec["py-cython"].command
+ for root, _, files in os.walk("."):
for fn in files:
- if fn.endswith('.pyx'):
+ if fn.endswith(".pyx"):
cython(os.path.join(root, fn))