summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-pillow/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-pillow/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-pillow/package.py7
1 files changed, 0 insertions, 7 deletions
diff --git a/var/spack/repos/builtin/packages/py-pillow/package.py b/var/spack/repos/builtin/packages/py-pillow/package.py
index 04355b9665..8f96e2a8f5 100644
--- a/var/spack/repos/builtin/packages/py-pillow/package.py
+++ b/var/spack/repos/builtin/packages/py-pillow/package.py
@@ -54,8 +54,6 @@ class PyPillowBase(PythonPackage):
conflicts('+imagequant', when='@:3.2', msg='imagequant support was added in 3.3')
conflicts('+xcb', when='@:7.0', msg='XCB support was added in 7.1')
- phases = ['build_ext', 'install']
-
def patch(self):
"""Patch setup.py to provide library and include directories
for dependencies."""
@@ -95,11 +93,6 @@ class PyPillowBase(PythonPackage):
def setup_build_environment(self, env):
env.set('MAX_CONCURRENCY', str(make_jobs))
- # Tests need to be re-added since `phases` was overridden
- run_after('install')(
- PythonPackage._run_default_install_time_test_callbacks)
- run_after('install')(PythonPackage.sanity_check_prefix)
-
class PyPillow(PyPillowBase):
"""Pillow is a fork of the Python Imaging Library (PIL). It adds image