summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-pillow/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-pillow/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-pillow/package.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-pillow/package.py b/var/spack/repos/builtin/packages/py-pillow/package.py
new file mode 100644
index 0000000000..adc8507bd5
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-pillow/package.py
@@ -0,0 +1,14 @@
+from spack import *
+
+class PyPillow(Package):
+ """Pillow is the friendly PIL fork by Alex Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and Contributors. The Python Imaging Library (PIL) adds image processing capabilities to your Python interpreter. This library supports many file formats, and provides powerful image processing and graphics capabilities."""
+
+ homepage = "https://python-pillow.github.io/"
+ url = "https://pypi.python.org/packages/source/P/Pillow/Pillow-3.0.0.tar.gz"
+
+ version('3.0.0', 'fc8ac44e93da09678eac7e30c9b7377d')
+ extends('python')
+ depends_on('py-setuptools')
+
+ def install(self, spec, prefix):
+ python('setup.py', 'install', '--prefix=%s' % prefix)