summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-pybind11/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-pybind11/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-pybind11/package.py53
1 files changed, 29 insertions, 24 deletions
diff --git a/var/spack/repos/builtin/packages/py-pybind11/package.py b/var/spack/repos/builtin/packages/py-pybind11/package.py
index aaa54370bf..b6e3118118 100644
--- a/var/spack/repos/builtin/packages/py-pybind11/package.py
+++ b/var/spack/repos/builtin/packages/py-pybind11/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -36,17 +17,41 @@ class PyPybind11(CMakePackage):
homepage = "https://pybind11.readthedocs.io"
url = "https://github.com/pybind/pybind11/archive/v2.1.0.tar.gz"
+ git = "https://github.com/pybind/pybind11.git"
+ version('develop', branch='master')
+ version('2.2.4', 'b69e83658513215b8d1443544d0549b7d231b9f201f6fc787a2b2218b408181e')
+ version('2.2.3', '55b637945bbf47d99d2c906bf0c13f49')
+ version('2.2.2', 'fc174e1bbfe7ec069af7eea86ec37b5c')
+ version('2.2.1', 'bab1d46bbc465af5af3a4129b12bfa3b')
version('2.2.0', '978b26aea1c6bfc4f88518ef33771af2')
version('2.1.1', '5518988698df937ccee53fb6ba91d12a')
version('2.1.0', '3cf07043d677d200720c928569635e12')
- depends_on('py-pytest', type=('build'))
+ depends_on('py-pytest', type='test')
+ depends_on('py-setuptools', type='build')
extends('python')
+ # compiler support
+ conflicts('%gcc@:4.7')
+ conflicts('%clang@:3.2')
+ conflicts('%intel@:16')
+
def cmake_args(self):
args = []
args.append('-DPYTHON_EXECUTABLE:FILEPATH=%s'
% self.spec['python'].command.path)
+ args += [
+ '-DPYBIND11_TEST:BOOL={0}'.format(
+ 'ON' if self.run_tests else 'OFF')
+ ]
return args
+
+ def setup_environment(self, spack_env, run_env):
+ spack_env.set('PYBIND11_USE_CMAKE', 1)
+
+ def install(self, spec, prefix):
+ super(PyPybind11, self).install(spec, prefix)
+ setup_py('install', '--single-version-externally-managed', '--root=/',
+ '--prefix={0}'.format(prefix))