summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-pydmd/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-pydmd/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-pydmd/package.py42
1 files changed, 21 insertions, 21 deletions
diff --git a/var/spack/repos/builtin/packages/py-pydmd/package.py b/var/spack/repos/builtin/packages/py-pydmd/package.py
index 56d3490142..2f5c2762d6 100644
--- a/var/spack/repos/builtin/packages/py-pydmd/package.py
+++ b/var/spack/repos/builtin/packages/py-pydmd/package.py
@@ -12,34 +12,34 @@ class PyPydmd(PythonPackage):
coherent structures."""
homepage = "https://mathlab.github.io/PyDMD/"
- url = "https://github.com/mathLab/PyDMD/archive/v0.3.tar.gz"
+ url = "https://github.com/mathLab/PyDMD/archive/v0.3.tar.gz"
- version('0.3', sha256='f490fc139677e4d9fc1240636a2c5992d22879517c9574d13164dc5179b0f785')
+ version("0.3", sha256="f490fc139677e4d9fc1240636a2c5992d22879517c9574d13164dc5179b0f785")
- variant('docs', default=False, description='Build HTML documentation')
+ variant("docs", default=False, description="Build HTML documentation")
- depends_on('python@3:', type=('build', 'run'))
- depends_on('py-setuptools', type='build')
- depends_on('py-numpy', type=('build', 'run'))
- depends_on('py-scipy', type=('build', 'run'))
- depends_on('py-matplotlib', type=('build', 'run'))
- depends_on('py-future', type=('build', 'run'))
- depends_on('py-nose', type='test')
- depends_on('texlive', type='build', when='+docs')
- depends_on('py-sphinx@1.4.0:1.4', type='build', when='+docs')
- depends_on('py-sphinx-rtd-theme', type='build', when='+docs')
+ depends_on("python@3:", type=("build", "run"))
+ depends_on("py-setuptools", type="build")
+ depends_on("py-numpy", type=("build", "run"))
+ depends_on("py-scipy", type=("build", "run"))
+ depends_on("py-matplotlib", type=("build", "run"))
+ depends_on("py-future", type=("build", "run"))
+ depends_on("py-nose", type="test")
+ depends_on("texlive", type="build", when="+docs")
+ depends_on("py-sphinx@1.4.0:1.4", type="build", when="+docs")
+ depends_on("py-sphinx-rtd-theme", type="build", when="+docs")
# https://github.com/mathLab/PyDMD/pull/133
- patch('isuue-133.patch', when='@0.3')
+ patch("isuue-133.patch", when="@0.3")
- @run_after('install')
+ @run_after("install")
def install_docs(self):
- if '+docs' in self.spec:
- with working_dir('docs'):
- make('html')
- install_tree('docs', self.prefix.docs)
+ if "+docs" in self.spec:
+ with working_dir("docs"):
+ make("html")
+ install_tree("docs", self.prefix.docs)
- @run_after('install')
+ @run_after("install")
@on_package_attributes(run_tests=True)
def build_test(self):
- python('test.py')
+ python("test.py")