summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-pypar/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-pypar/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-pypar/package.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-pypar/package.py b/var/spack/repos/builtin/packages/py-pypar/package.py
new file mode 100644
index 0000000000..af9c76ccd8
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-pypar/package.py
@@ -0,0 +1,14 @@
+from spack import *
+
+class PyPypar(Package):
+ """Pypar is an efficient but easy-to-use module that allows programs written in Python to run in parallel on multiple processors and communicate using MPI."""
+ homepage = "http://code.google.com/p/pypar/"
+ url = "https://pypar.googlecode.com/files/pypar-2.1.5_108.tgz"
+
+ version('2.1.5_108', '7a1f28327d2a3b679f9455c843d850b8', url='https://pypar.googlecode.com/files/pypar-2.1.5_108.tgz')
+ extends('python')
+ depends_on('mpi')
+
+ def install(self, spec, prefix):
+ with working_dir('source'):
+ python('setup.py', 'install', '--prefix=%s' % prefix)