summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-pytables/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-pytables/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-pytables/package.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-pytables/package.py b/var/spack/repos/builtin/packages/py-pytables/package.py
new file mode 100644
index 0000000000..a5b1e78ab3
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-pytables/package.py
@@ -0,0 +1,19 @@
+from spack import *
+import re
+
+class PyPytables(Package):
+ """PyTables is a package for managing hierarchical datasets and designed to efficiently and easily cope with extremely large amounts of data."""
+ homepage = "http://www.pytables.org/"
+ url = "https://github.com/PyTables/PyTables/archive/v.3.2.2.tar.gz"
+
+ version('3.2.2', '7cbb0972e4d6580f629996a5bed92441')
+
+ extends('python')
+ depends_on('hdf5')
+ depends_on('py-numpy')
+ depends_on('py-numexpr')
+ depends_on('py-cython')
+
+ def install(self, spec, prefix):
+ env["HDF5_DIR"] = spec['hdf5'].prefix
+ python('setup.py', 'install', '--prefix=%s' % prefix)