summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-scipy/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-scipy/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-scipy/package.py31
1 files changed, 2 insertions, 29 deletions
diff --git a/var/spack/repos/builtin/packages/py-scipy/package.py b/var/spack/repos/builtin/packages/py-scipy/package.py
index 7f6027c0e1..c01d47e55e 100644
--- a/var/spack/repos/builtin/packages/py-scipy/package.py
+++ b/var/spack/repos/builtin/packages/py-scipy/package.py
@@ -16,20 +16,6 @@ class PyScipy(PythonPackage):
git = "https://github.com/scipy/scipy.git"
maintainers = ['adamjstewart']
- install_time_test_callbacks = ['install_test', 'import_module_test']
-
- import_modules = [
- 'scipy', 'scipy._build_utils', 'scipy._lib', 'scipy.cluster',
- 'scipy.constants', 'scipy.fftpack', 'scipy.integrate',
- 'scipy.interpolate', 'scipy.io', 'scipy.linalg', 'scipy.misc',
- 'scipy.ndimage', 'scipy.odr', 'scipy.optimize', 'scipy.signal',
- 'scipy.sparse', 'scipy.spatial', 'scipy.special', 'scipy.stats',
- 'scipy.io.arff', 'scipy.io.harwell_boeing', 'scipy.io.matlab',
- 'scipy.optimize._lsq', 'scipy.sparse.csgraph', 'scipy.sparse.linalg',
- 'scipy.sparse.linalg.dsolve', 'scipy.sparse.linalg.eigen',
- 'scipy.sparse.linalg.isolve', 'scipy.sparse.linalg.eigen.arpack',
- 'scipy.sparse.linalg.eigen.lobpcg', 'scipy.special._precompute'
- ]
version('master', branch='master')
version('1.5.4', sha256='4a453d5e5689de62e5d38edf40af3f17560bfd63c9c5bd228c18c1f99afa155b')
@@ -107,21 +93,8 @@ class PyScipy(PythonPackage):
return args
- def build_test(self):
- # `setup.py test` is not supported. Use one of the following
- # instead:
- #
- # - `python runtests.py` (to build and test)
- # - `python runtests.py --no-build` (to test installed scipy)
- # - `>>> scipy.test()` (run tests for installed scipy
- # from within an interpreter)
- pass
-
+ @run_after('install')
+ @on_package_attributes(run_tests=True)
def install_test(self):
- # Change directories due to the following error:
- #
- # ImportError: Error importing scipy: you should not try to import
- # scipy from its source directory; please exit the scipy
- # source tree, and relaunch your python interpreter from there.
with working_dir('spack-test', create=True):
python('-c', 'import scipy; scipy.test("full", verbose=2)')