summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-tensorboard/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-tensorboard/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-tensorboard/package.py31
1 files changed, 23 insertions, 8 deletions
diff --git a/var/spack/repos/builtin/packages/py-tensorboard/package.py b/var/spack/repos/builtin/packages/py-tensorboard/package.py
index 337a64f41c..e761016d49 100644
--- a/var/spack/repos/builtin/packages/py-tensorboard/package.py
+++ b/var/spack/repos/builtin/packages/py-tensorboard/package.py
@@ -16,15 +16,20 @@ class PyTensorboard(Package):
maintainers = ['aweits']
+ version('2.7.0', sha256='5632812bb9450e5741083b5b7826244ffdb732fb5bce970d526c81874a3e7fb2')
+ version('2.6.0', sha256='3d1e0a05828b25c1c28bd90c73d981a0a65c6a5550510bc7983d03ab915e6503')
+ version('2.5.0', sha256='58c9e0c31062821ab1c02845c3b7902da92574ef7192d701b1828dacbe4ee610')
version('2.4.1', sha256='736dc204aa292d221f5871077e60994a9a9ea8e33b841f0d754d510fe6cc7635')
version('2.4.0', sha256='28a30794c1c797357b2086477394b59afa0b18ca48592ca3c0627f7f10536373')
version('2.3.0', sha256='947a58702c2841eb4559637dbf8639633f79de9a0f422be9737f3563a1725440')
version('2.2.0', sha256='d0dfbf0e4b3b5ebbc3fafa6d281d4b9aa5478eac6bac3330652ab6674278ab77')
- depends_on('python@2.7:2.8,3.2:', type=('build', 'run'))
+ depends_on('python@2.7:2.8,3.2:', type=('build', 'run'), when='@:2.5')
+ depends_on('python@3.6:', type=('build', 'run'), when='@2.6:')
depends_on('bazel@2.1.0:', type='build', when='@2.2.0:')
+ depends_on('bazel@3.7.0:', type='build', when='@2.5.0:')
depends_on('py-pip', type='build')
- depends_on('py-wheel', type='build')
+ depends_on('py-wheel@0.26:', type='build')
depends_on('py-setuptools@41.0.0:', type=('build', 'run'))
depends_on('py-absl-py@0.4:', type=('build', 'run'))
depends_on('py-markdown@2.6.8:', type=('build', 'run'))
@@ -32,22 +37,31 @@ class PyTensorboard(Package):
depends_on('py-futures@3.1.1:', type=('build', 'run'), when='^python@:2')
depends_on('py-grpcio@1.24.3:', type=('build', 'run'), when='@2.3:')
depends_on('py-grpcio@1.23.3:', type=('build', 'run'), when='@2.2')
- depends_on('py-google-auth@1.6.3:1', type=('build', 'run'))
+ depends_on('py-google-auth@1.6.3:1', type=('build', 'run'), when='@:2.6')
+ depends_on('py-google-auth@1.6.3:2', type=('build', 'run'), when='@2.7:')
depends_on('py-numpy@1.12.0:', type=('build', 'run'))
depends_on('py-protobuf@3.6.0:', type=('build', 'run'))
- depends_on('py-six@1.10.0:', type=('build', 'run'))
+ depends_on('py-six@1.10.0:', type=('build', 'run'), when='@:2.4')
depends_on('py-werkzeug@0.11.15:', type=('build', 'run'))
- depends_on('py-wheel', type=('build', 'run'))
- depends_on('py-wheel@0.26:', type=('build', 'run'), when='@0.6: ^python@3:')
depends_on('py-google-auth-oauthlib@0.4.1:0.4', type=('build', 'run'))
- depends_on('py-tensorboard-plugin-wit@1.6.0:', type=('build', 'run'), when='@2.2.0:')
+
+ depends_on('py-tensorboard-plugin-wit@1.6.0:', type=('build', 'run'))
+
+ depends_on('py-tensorboard-data-server@0.6', type=('build', 'run'), when='@2.5:')
extends('python')
- patch('tboard_shellenv.patch')
+ patch('tboard_shellenv.patch', when='@:2.4')
+ patch('webapp.patch', when='@2.7:')
+ patch('vz_projector.patch', when='@2.7:')
phases = ['configure', 'build', 'install']
+ # Version 2.6.0 and above do not build in parallel
+ @property
+ def parallel(self):
+ return self.spec.version < Version('2.6.0')
+
def patch(self):
filter_file('build --define=angular_ivy_enabled=True',
'build --define=angular_ivy_enabled=True\n'
@@ -100,6 +114,7 @@ class PyTensorboard(Package):
'--verbose_failures',
'--spawn_strategy=local',
'--subcommands=pretty_print',
+ '--jobs={0}'.format(make_jobs),
'//tensorboard/pip_package')
def install(self, spec, prefix):