summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/qrupdate/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/qrupdate/package.py')
-rw-r--r--var/spack/repos/builtin/packages/qrupdate/package.py45
1 files changed, 23 insertions, 22 deletions
diff --git a/var/spack/repos/builtin/packages/qrupdate/package.py b/var/spack/repos/builtin/packages/qrupdate/package.py
index 603769ba3e..ad8714d428 100644
--- a/var/spack/repos/builtin/packages/qrupdate/package.py
+++ b/var/spack/repos/builtin/packages/qrupdate/package.py
@@ -16,7 +16,7 @@ class Qrupdate(MakefilePackage, SourceforgePackage):
homepage = "https://sourceforge.net/projects/qrupdate/"
sourceforge_mirror_path = "qrupdate/qrupdate-1.1.2.tar.gz"
- version('1.1.2', sha256='e2a1c711dc8ebc418e21195833814cb2f84b878b90a2774365f0166402308e08')
+ version("1.1.2", sha256="e2a1c711dc8ebc418e21195833814cb2f84b878b90a2774365f0166402308e08")
depends_on("blas")
depends_on("lapack")
@@ -24,43 +24,44 @@ class Qrupdate(MakefilePackage, SourceforgePackage):
def edit(self, spec, prefix):
# BSD "install" does not understand GNU -D flag.
# We will create the parent directory ourselves.
- if (sys.platform == 'darwin'):
- makefile = FileFilter('src/Makefile')
- makefile.filter('-D', '')
+ if sys.platform == "darwin":
+ makefile = FileFilter("src/Makefile")
+ makefile.filter("-D", "")
# Concurrent (parallel) Compilation requires calling $(MAKE) not make
- makefile = FileFilter('Makefile')
- makefile.filter('make', '$(MAKE)')
+ makefile = FileFilter("Makefile")
+ makefile.filter("make", "$(MAKE)")
# We may like to compile with any Forran compiler, not always gfortran
- makefile = FileFilter('Makeconf')
- makefile.filter('FC=gfortran', 'FC ?= gfortran')
+ makefile = FileFilter("Makeconf")
+ makefile.filter("FC=gfortran", "FC ?= gfortran")
return
# The Makefile does not take the simple "make" rule
def build(self, spec, prefix):
- lapack_blas = spec['lapack'].libs + spec['blas'].libs
+ lapack_blas = spec["lapack"].libs + spec["blas"].libs
make_args = [
- 'BLAS={0}'.format(lapack_blas.ld_flags),
- 'LAPACK={0}'.format(lapack_blas.ld_flags)
+ "BLAS={0}".format(lapack_blas.ld_flags),
+ "LAPACK={0}".format(lapack_blas.ld_flags),
]
# If 64-bit BLAS is used:
- if (spec.satisfies('^openblas+ilp64') or
- spec.satisfies('^intel-mkl+ilp64') or
- spec.satisfies('^intel-parallel-studio+mkl+ilp64')):
- if (spec.satisfies('%intel') or spec.satisfies('%oneapi')
- or spec.satisfies('%nvhpc')):
+ if (
+ spec.satisfies("^openblas+ilp64")
+ or spec.satisfies("^intel-mkl+ilp64")
+ or spec.satisfies("^intel-parallel-studio+mkl+ilp64")
+ ):
+ if spec.satisfies("%intel") or spec.satisfies("%oneapi") or spec.satisfies("%nvhpc"):
# 64bits integer for ifort and nvfortran are promoted by:
- make_args.append('FFLAGS=-i8')
+ make_args.append("FFLAGS=-i8")
else:
- make_args.append('FFLAGS=-fdefault-integer-8')
+ make_args.append("FFLAGS=-fdefault-integer-8")
# Build static and dynamic libraries:
- make('lib', 'solib', *make_args)
+ make("lib", "solib", *make_args)
def install(self, spec, prefix):
# "INSTALL" confuses "make install" on case-insensitive filesystems:
@@ -68,13 +69,13 @@ class Qrupdate(MakefilePackage, SourceforgePackage):
os.remove("INSTALL")
# Create lib folder:
- if (sys.platform == 'darwin'):
+ if sys.platform == "darwin":
mkdirp(prefix.lib)
make("install", "PREFIX=%s" % prefix)
- @run_after('install')
+ @run_after("install")
def fix_darwin_install(self):
# The shared libraries are not installed correctly on Darwin:
- if (sys.platform == 'darwin'):
+ if sys.platform == "darwin":
fix_darwin_install_name(self.spec.prefix.lib)