summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/reditools/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/reditools/package.py')
-rw-r--r--var/spack/repos/builtin/packages/reditools/package.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/reditools/package.py b/var/spack/repos/builtin/packages/reditools/package.py
index 64df6ffce8..8c9c0c7500 100644
--- a/var/spack/repos/builtin/packages/reditools/package.py
+++ b/var/spack/repos/builtin/packages/reditools/package.py
@@ -27,6 +27,8 @@ class Reditools(PythonPackage):
variant('nature_protocol', default=False,
description='Install the Nature Protocol scripts and files')
+ # pip silently replaces distutils with setuptools
+ depends_on('py-setuptools', type='build')
depends_on('py-reindent', type='build', when='^python@3:')
depends_on('blat', type='run')
depends_on('py-fisher', type='run')
@@ -57,7 +59,7 @@ class Reditools(PythonPackage):
patch('setup.py.patch')
patch('batch_sort.patch', when='^python@3:')
- @run_before('build')
+ @run_before('install')
def p2_to_p3(self):
if '^python@3:' in self.spec:
# clean up space/tab mixing