summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/rivet/rivet-2.5.4.patch
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/rivet/rivet-2.5.4.patch')
-rw-r--r--var/spack/repos/builtin/packages/rivet/rivet-2.5.4.patch42
1 files changed, 0 insertions, 42 deletions
diff --git a/var/spack/repos/builtin/packages/rivet/rivet-2.5.4.patch b/var/spack/repos/builtin/packages/rivet/rivet-2.5.4.patch
deleted file mode 100644
index af338da6d5..0000000000
--- a/var/spack/repos/builtin/packages/rivet/rivet-2.5.4.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-patch written by GENSER to avoid system libraries of GLS coming from fastjet-config
---- include/Rivet/Tools/JetUtils.hh
-+++ include/Rivet/Tools/JetUtils.hh
-@@ -47,4 +47,5 @@
- struct BoolJetFunctor {
- virtual bool operator()(const Jet& p) const = 0;
-+ virtual ~BoolJetFunctor() {}
- };
-
---- include/Rivet/Tools/ParticleBaseUtils.hh
-+++ include/Rivet/Tools/ParticleBaseUtils.hh
-@@ -23,4 +23,5 @@
- struct BoolParticleBaseFunctor {
- virtual bool operator()(const ParticleBase& p) const = 0;
-+ virtual ~BoolParticleBaseFunctor() {}
- };
-
-@@ -397,4 +398,5 @@
- struct DoubleParticleBaseFunctor {
- virtual double operator()(const ParticleBase& p) const = 0;
-+ virtual ~DoubleParticleBaseFunctor() {}
- };
-
---- include/Rivet/Tools/ParticleUtils.hh
-+++ include/Rivet/Tools/ParticleUtils.hh
-@@ -486,4 +486,5 @@
- struct BoolParticleFunctor {
- virtual bool operator()(const Particle& p) const = 0;
-+ virtual ~BoolParticleFunctor() {}
- };
-
---- src/Makefile.in.orig 2018-01-30 13:52:58.641670247 +0100
-+++ src/Makefile.in 2018-01-30 13:53:19.377586118 +0100
-@@ -449,7 +449,7 @@
- libRivet_la_SOURCES =
- libRivet_la_LDFLAGS = -export-dynamic -avoid-version -L$(YODALIBPATH) -L$(HEPMCLIBPATH)
- libRivet_la_LIBADD = Core/libRivetCore.la Projections/libRivetProjections.la Tools/libRivetTools.la $(ANA_LIBADD) \
-- -lYODA -lHepMC -ldl -lm $(FASTJETCONFIGLIBADD) $(GSL_LDFLAGS)
-+ -lYODA -lHepMC -ldl -lm $(GSL_LDFLAGS) $(FASTJETCONFIGLIBADD)
-
- all: all-recursive
-