summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/rocsparse/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/rocsparse/package.py')
-rw-r--r--var/spack/repos/builtin/packages/rocsparse/package.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/rocsparse/package.py b/var/spack/repos/builtin/packages/rocsparse/package.py
new file mode 100644
index 0000000000..b5516f841b
--- /dev/null
+++ b/var/spack/repos/builtin/packages/rocsparse/package.py
@@ -0,0 +1,35 @@
+# Copyright 2013-2020 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class Rocsparse(CMakePackage):
+ """rocSPARSE exposes a common interface that provides
+ Basic Linear Algebra Subroutines for sparse computation
+ implemented on top of AMD's Radeon Open eCosystem Platform ROCm runtime
+ and toolchains. rocSPARSE is created using the HIP programming
+ language and optimized for AMD's latest discrete GPUs."""
+
+ homepage = "https://github.com/ROCmSoftwarePlatform/rocSPARSE"
+ url = "https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-3.5.0.tar.gz"
+
+ maintainers = ['srekolam', 'arjun-raj-kuppala']
+
+ version('3.5.0', sha256='9ca6bae7da78abbb47143c3d77ff4a8cd7d63979875fc7ebc46b400769fd9cb5')
+
+ depends_on('cmake@3:', type='build')
+ depends_on('boost', type='build')
+ for ver in ['3.5.0']:
+ depends_on('hip@' + ver, type='build', when='@' + ver)
+ depends_on('rocm-device-libs@' + ver, type='build', when='@' + ver)
+ depends_on('comgr@' + ver, type='build', when='@' + ver)
+ depends_on('rocprim@' + ver, type='build', when='@' + ver)
+ depends_on('llvm-amdgpu@' + ver, type='build', when='@' + ver)
+ depends_on('rocminfo@' + ver, type='build', when='@' + ver)
+ depends_on('hsa-rocr-dev@' + ver, type='build', when='@' + ver)
+
+ def setup_build_environment(self, env):
+ env.set('CXX', self.spec['hip'].hipcc)