summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/salmon/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/salmon/package.py')
-rw-r--r--var/spack/repos/builtin/packages/salmon/package.py35
1 files changed, 11 insertions, 24 deletions
diff --git a/var/spack/repos/builtin/packages/salmon/package.py b/var/spack/repos/builtin/packages/salmon/package.py
index a323aa1dab..06bfd70324 100644
--- a/var/spack/repos/builtin/packages/salmon/package.py
+++ b/var/spack/repos/builtin/packages/salmon/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -32,9 +13,15 @@ class Salmon(CMakePackage):
homepage = "http://combine-lab.github.io/salmon/"
url = "https://github.com/COMBINE-lab/salmon/archive/v0.8.2.tar.gz"
+ version('0.9.1', '1277b8ed65d2c6982ed176a496a2a1e3')
version('0.8.2', 'ee512697bc44b13661a16d4e14cf0a00')
- depends_on('boost')
+ depends_on('tbb')
+ depends_on('boost@:1.66.0')
+
+ def patch(self):
+ # remove static linking to libstdc++
+ filter_file('-static-libstdc++', '', 'CMakeLists.txt', string=True)
def cmake_args(self):
args = ['-DBOOST_ROOT=%s' % self.spec['boost'].prefix]