summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/serf/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/serf/package.py')
-rw-r--r--var/spack/repos/builtin/packages/serf/package.py40
1 files changed, 17 insertions, 23 deletions
diff --git a/var/spack/repos/builtin/packages/serf/package.py b/var/spack/repos/builtin/packages/serf/package.py
index 5604b8b166..6135a4ecfa 100644
--- a/var/spack/repos/builtin/packages/serf/package.py
+++ b/var/spack/repos/builtin/packages/serf/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -54,6 +35,19 @@ class Serf(SConsPackage):
'ZLIB={0}'.format(spec['zlib'].prefix),
]
+ # ZLIB variable is ignored on non-Windows platforms before and
+ # including the version 1.3.9:
+ # https://www.mail-archive.com/dev@serf.apache.org/msg01359.html
+ # The issue is fixed in the trunk. Hopefully, the next stable version
+ # will work properly.
+ if '@:1.3.9' in self.spec:
+ zlib_spec = self.spec['zlib']
+ link_flags = [zlib_spec.libs.search_flags]
+ link_flags.extend([self.compiler.cc_rpath_arg + d
+ for d in zlib_spec.libs.directories])
+ args.append('LINKFLAGS=' + ' '.join(link_flags))
+ args.append('CPPFLAGS=' + zlib_spec.headers.cpp_flags)
+
if '+debug' in spec:
args.append('DEBUG=yes')
else: