summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/shiny-server/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/shiny-server/package.py')
-rw-r--r--var/spack/repos/builtin/packages/shiny-server/package.py37
1 files changed, 18 insertions, 19 deletions
diff --git a/var/spack/repos/builtin/packages/shiny-server/package.py b/var/spack/repos/builtin/packages/shiny-server/package.py
index 036cd124ce..05fe93b3f7 100644
--- a/var/spack/repos/builtin/packages/shiny-server/package.py
+++ b/var/spack/repos/builtin/packages/shiny-server/package.py
@@ -8,8 +8,8 @@ from spack.package import *
class ShinyServer(CMakePackage):
"""Shiny server lets you put shiny web applications and interactive
- documents online. Take your shiny apps and share them with your
- organization or the world."""
+ documents online. Take your shiny apps and share them with your
+ organization or the world."""
#
# HEADS UP:
@@ -23,36 +23,35 @@ class ShinyServer(CMakePackage):
homepage = "https://www.rstudio.com/products/shiny/shiny-server/"
url = "https://github.com/rstudio/shiny-server/archive/v1.5.3.838.tar.gz"
- version('1.5.3.838', sha256='6fd1b12cd1cbe5c64cacbec4accefe955353f9c675e5feff809c0e911a382141')
+ version("1.5.3.838", sha256="6fd1b12cd1cbe5c64cacbec4accefe955353f9c675e5feff809c0e911a382141")
- depends_on('python@:2.8') # docs say: "Really. 3.x will not work"
- depends_on('cmake@2.8.10:', type='build')
- depends_on('git')
- depends_on('r+X')
- depends_on('openssl')
+ depends_on("python@:2.8") # docs say: "Really. 3.x will not work"
+ depends_on("cmake@2.8.10:", type="build")
+ depends_on("git")
+ depends_on("r+X")
+ depends_on("openssl")
def cmake_args(self):
spec = self.spec
options = []
- options.append("-DPYTHON=%s" % spec['python'].command.path)
+ options.append("-DPYTHON=%s" % spec["python"].command.path)
return options
# Recompile the npm modules included in the project
- @run_after('build')
+ @run_after("build")
def build_node(self):
- bash = which('bash')
- mkdirp('build')
- bash('-c', 'bin/npm --python="$PYTHON" install')
+ bash = which("bash")
+ mkdirp("build")
+ bash("-c", 'bin/npm --python="$PYTHON" install')
bash(
- '-c',
- 'bin/node ./ext/node/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js '
- '--python="$PYTHON" rebuild'
+ "-c",
+ "bin/node ./ext/node/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js "
+ '--python="$PYTHON" rebuild',
)
def setup_run_environment(self, env):
- env.prepend_path('PATH', join_path(self.prefix, 'shiny-server', 'bin'))
+ env.prepend_path("PATH", join_path(self.prefix, "shiny-server", "bin"))
# shiny comes with its own pandoc; hook it up...
- env.prepend_path('PATH', join_path(
- self.prefix, 'shiny-server', 'ext', 'pandoc', 'static'))
+ env.prepend_path("PATH", join_path(self.prefix, "shiny-server", "ext", "pandoc", "static"))