summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/shoremap/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/shoremap/package.py')
-rw-r--r--var/spack/repos/builtin/packages/shoremap/package.py28
1 files changed, 13 insertions, 15 deletions
diff --git a/var/spack/repos/builtin/packages/shoremap/package.py b/var/spack/repos/builtin/packages/shoremap/package.py
index 84305f14e4..7497bd47c4 100644
--- a/var/spack/repos/builtin/packages/shoremap/package.py
+++ b/var/spack/repos/builtin/packages/shoremap/package.py
@@ -8,28 +8,26 @@ from spack.package import *
class Shoremap(MakefilePackage):
"""SHOREmap is a computational tool implementing a method that enables
- simple and straightforward mapping-by-sequencing analysis.
+ simple and straightforward mapping-by-sequencing analysis.
- Whole genome resequencing of pools of recombinant mutant genomes allows
- directly linking phenotypic traits to causal mutations. Such an
- analysis, called mapping-by-sequencing, combines classical genetic
- mapping and next generation sequencing by relying on selection-induced
- patterns within genome-wide allele frequency in pooled genomes."""
+ Whole genome resequencing of pools of recombinant mutant genomes allows
+ directly linking phenotypic traits to causal mutations. Such an
+ analysis, called mapping-by-sequencing, combines classical genetic
+ mapping and next generation sequencing by relying on selection-induced
+ patterns within genome-wide allele frequency in pooled genomes."""
homepage = "http://bioinfo.mpipz.mpg.de/shoremap/"
- url = "http://bioinfo.mpipz.mpg.de/shoremap/SHOREmap_v3.6.tar.gz"
+ url = "http://bioinfo.mpipz.mpg.de/shoremap/SHOREmap_v3.6.tar.gz"
- version('3.6', sha256='0da4179e92cbc68434a9d8eff7bd5fff55c89fd9a543a2db6bd0f69074f2ec70')
+ version("3.6", sha256="0da4179e92cbc68434a9d8eff7bd5fff55c89fd9a543a2db6bd0f69074f2ec70")
- depends_on('dislin')
+ depends_on("dislin")
def edit(self, spec, prefix):
- makefile = FileFilter('makefile')
- makefile.filter(r'-L/usr/lib/',
- self.spec['libxt'].libs.search_flags)
- makefile.filter(r'-L\./dislin.* -ldislin_d',
- self.spec['dislin:d'].libs.ld_flags)
+ makefile = FileFilter("makefile")
+ makefile.filter(r"-L/usr/lib/", self.spec["libxt"].libs.search_flags)
+ makefile.filter(r"-L\./dislin.* -ldislin_d", self.spec["dislin:d"].libs.ld_flags)
def install(self, spec, prefix):
mkdirp(prefix.bin)
- install('SHOREmap', prefix.bin)
+ install("SHOREmap", prefix.bin)