summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/shuffile/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/shuffile/package.py')
-rw-r--r--var/spack/repos/builtin/packages/shuffile/package.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/shuffile/package.py b/var/spack/repos/builtin/packages/shuffile/package.py
new file mode 100644
index 0000000000..2bc1c28ca5
--- /dev/null
+++ b/var/spack/repos/builtin/packages/shuffile/package.py
@@ -0,0 +1,30 @@
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class Shuffile(CMakePackage):
+ """Shuffle files between MPI ranks"""
+
+ homepage = "https://github.com/ECP-VeloC/shuffile"
+ url = "https://github.com/ECP-VeloC/shuffile/archive/v0.0.2.zip"
+ git = "https://github.com/ecp-veloc/shuffile.git"
+
+ tags = ['ecp']
+
+ version('master', branch='master')
+ version('0.0.3', sha256='6debdd9d6e6f1c4ec31015d7956e8b556acd61ce31f757e4d1fa5002029c75e2')
+
+ depends_on('mpi')
+ depends_on('kvtree')
+
+ def cmake_args(self):
+ args = []
+ args.append("-DMPI_C_COMPILER=%s" % self.spec['mpi'].mpicc)
+ if self.spec.satisfies('platform=cray'):
+ args.append("-DSHUFFILE_LINK_STATIC=ON")
+ args.append("-DWITH_KVTREE_PREFIX=%s" % self.spec['kvtree'].prefix)
+ return args