summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/stc/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/stc/package.py')
-rw-r--r--var/spack/repos/builtin/packages/stc/package.py38
1 files changed, 10 insertions, 28 deletions
diff --git a/var/spack/repos/builtin/packages/stc/package.py b/var/spack/repos/builtin/packages/stc/package.py
index 7a55b73873..7332d4843d 100644
--- a/var/spack/repos/builtin/packages/stc/package.py
+++ b/var/spack/repos/builtin/packages/stc/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -30,13 +11,14 @@ class Stc(AutotoolsPackage):
"""STC: The Swift-Turbine Compiler"""
homepage = 'http://swift-lang.org/Swift-T'
- url = 'http://swift-lang.github.io/swift-t-downloads/stc-0.7.3.tar.gz'
+ url = 'http://swift-lang.github.io/swift-t-downloads/spack/stc-0.0.0.tar.gz'
- version('0.7.3', '6bf769f406f6c33d1c134521373718d3')
+ version('0.8.2', '883b0657f1aac9b81158ef0a8989be4c')
- depends_on('java')
- depends_on('ant')
- depends_on('turbine')
+ depends_on('java', type=('build', 'run'))
+ depends_on('ant', type='build')
+ depends_on('turbine', type=('build', 'run'))
+ depends_on('zsh', type=('build', 'run'))
def configure_args(self):
args = ['--with-turbine=' + self.spec['turbine'].prefix]