summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/suite-sparse/graphblas_libm_dep.patch
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/suite-sparse/graphblas_libm_dep.patch')
-rw-r--r--var/spack/repos/builtin/packages/suite-sparse/graphblas_libm_dep.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/suite-sparse/graphblas_libm_dep.patch b/var/spack/repos/builtin/packages/suite-sparse/graphblas_libm_dep.patch
new file mode 100644
index 0000000000..441b0eff87
--- /dev/null
+++ b/var/spack/repos/builtin/packages/suite-sparse/graphblas_libm_dep.patch
@@ -0,0 +1,10 @@
+--- a/GraphBLAS/CMakeLists.txt
++++ b/GraphBLAS/CMakeLists.txt
+@@ -87,6 +87,7 @@
+ C_STANDARD_REQUIRED 11
+ PUBLIC_HEADER "Include/GraphBLAS.h" )
+ set_property ( TARGET graphblas PROPERTY C_STANDARD 11 )
++target_link_libraries ( graphblas m )
+
+ # create the static graphblas library. Requires ANSI C11
+ add_library ( graphblas_static STATIC ${GRAPHBLAS_SOURCES} )