summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/swipl/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/swipl/package.py')
-rw-r--r--var/spack/repos/builtin/packages/swipl/package.py72
1 files changed, 36 insertions, 36 deletions
diff --git a/var/spack/repos/builtin/packages/swipl/package.py b/var/spack/repos/builtin/packages/swipl/package.py
index 2b3be29fd2..3a2ccb2c91 100644
--- a/var/spack/repos/builtin/packages/swipl/package.py
+++ b/var/spack/repos/builtin/packages/swipl/package.py
@@ -7,7 +7,7 @@ from spack.package import *
class Swipl(CMakePackage):
- """ SWI-Prolog is a versatile implementation of the Prolog language.
+ """SWI-Prolog is a versatile implementation of the Prolog language.
Although SWI-Prolog gained its popularity primarily in education,
its development is mostly driven by the needs for application development.
This is facilitated by a rich interface to other IT components by
@@ -20,58 +20,58 @@ class Swipl(CMakePackage):
with other components."""
homepage = "https://www.swi-prolog.org"
- url = "https://www.swi-prolog.org/download/stable/src/swipl-8.0.3.tar.gz"
+ url = "https://www.swi-prolog.org/download/stable/src/swipl-8.0.3.tar.gz"
- maintainers = ['alexrobomind']
+ maintainers = ["alexrobomind"]
- version('8.2.0', sha256='d8c9f3adb9cd997a5fed7b5f5dbfe971d2defda969b9066ada158e4202c09c3c')
- version('8.0.3', sha256='cee59c0a477c8166d722703f6e52f962028f3ac43a5f41240ecb45dbdbe2d6ae')
+ version("8.2.0", sha256="d8c9f3adb9cd997a5fed7b5f5dbfe971d2defda969b9066ada158e4202c09c3c")
+ version("8.0.3", sha256="cee59c0a477c8166d722703f6e52f962028f3ac43a5f41240ecb45dbdbe2d6ae")
- variant('gmp', default=True, description='bignum and rational number support')
- variant('xpce', default=True, description='GUI support')
- variant('ssl', default=True, description='SSL support')
- variant('zlib', default=True, description='Compressed streams support')
- variant('odbc', default=True, description='ODBC database access')
- variant('unwind', default=True, description='Build with stack traces in crash reports')
- variant('html', default=True, description='Install the HTML documentation')
- variant('pdfdoc', default=False, description='Build the PDF documentation')
+ variant("gmp", default=True, description="bignum and rational number support")
+ variant("xpce", default=True, description="GUI support")
+ variant("ssl", default=True, description="SSL support")
+ variant("zlib", default=True, description="Compressed streams support")
+ variant("odbc", default=True, description="ODBC database access")
+ variant("unwind", default=True, description="Build with stack traces in crash reports")
+ variant("html", default=True, description="Install the HTML documentation")
+ variant("pdfdoc", default=False, description="Build the PDF documentation")
- depends_on('uuid')
- depends_on('readline')
+ depends_on("uuid")
+ depends_on("readline")
- depends_on('libarchive', when='+html')
+ depends_on("libarchive", when="+html")
- depends_on('gmp', when='+gmp')
- depends_on('unwind', when='+unwind')
- depends_on('unixodbc', when='+odbc')
- depends_on('openssl', when='+ssl')
- depends_on('zlib', when='+zlib')
+ depends_on("gmp", when="+gmp")
+ depends_on("unwind", when="+unwind")
+ depends_on("unixodbc", when="+odbc")
+ depends_on("openssl", when="+ssl")
+ depends_on("zlib", when="+zlib")
- depends_on('libxt', when='+xpce')
- depends_on('libx11', when='+xpce')
- depends_on('libjpeg', when='+xpce')
- depends_on('libxpm', when='+xpce')
+ depends_on("libxt", when="+xpce")
+ depends_on("libx11", when="+xpce")
+ depends_on("libjpeg", when="+xpce")
+ depends_on("libxpm", when="+xpce")
- depends_on('libxft', when='+xpce')
- depends_on('fontconfig', when='+xpce')
- depends_on('pkgconfig', when='+xpce', type='build')
+ depends_on("libxft", when="+xpce")
+ depends_on("fontconfig", when="+xpce")
+ depends_on("pkgconfig", when="+xpce", type="build")
- conflicts('%intel', msg='Test builds with ICC failed when creating startup image')
+ conflicts("%intel", msg="Test builds with ICC failed when creating startup image")
def cmake_args(self):
args = []
def append_switch(variant, cmake_flag):
- val = 'ON' if variant in self.spec else 'OFF'
+ val = "ON" if variant in self.spec else "OFF"
- flagdef = '-D' + cmake_flag + ':BOOL=' + val
+ flagdef = "-D" + cmake_flag + ":BOOL=" + val
args.append(flagdef)
- append_switch('+gmp', 'USE_GMP')
- append_switch('+xpce', 'SWIPL_PACKAGES_X')
- append_switch('+odbc', 'SWIPL_PACKAGES_ODBC')
- append_switch('+html', 'INSTALL_DOCUMENTATION')
- append_switch('+pdfdoc', 'BUILD_PDF_DOCUMENTATION')
+ append_switch("+gmp", "USE_GMP")
+ append_switch("+xpce", "SWIPL_PACKAGES_X")
+ append_switch("+odbc", "SWIPL_PACKAGES_ODBC")
+ append_switch("+html", "INSTALL_DOCUMENTATION")
+ append_switch("+pdfdoc", "BUILD_PDF_DOCUMENTATION")
# The variants ssl and zlib are implicitly set up by CMake