summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/thrift/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/thrift/package.py')
-rw-r--r--var/spack/repos/builtin/packages/thrift/package.py37
1 files changed, 13 insertions, 24 deletions
diff --git a/var/spack/repos/builtin/packages/thrift/package.py b/var/spack/repos/builtin/packages/thrift/package.py
index 9e296123fd..35d3a897e9 100644
--- a/var/spack/repos/builtin/packages/thrift/package.py
+++ b/var/spack/repos/builtin/packages/thrift/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -38,6 +19,7 @@ class Thrift(Package):
homepage = "http://thrift.apache.org"
url = "http://apache.mirrors.ionfish.org/thrift/0.9.2/thrift-0.9.2.tar.gz"
+ version('0.11.0', '0be59730ebce071eceaf6bfdb8d3a20e')
version('0.10.0', '795c5dd192e310ffff38cfd9430d6b29')
version('0.9.3', '88d667a8ae870d5adeca8cb7d6795442')
version('0.9.2', '89f63cc4d0100912f4a1f8a9dee63678')
@@ -45,6 +27,8 @@ class Thrift(Package):
# Currently only support for c-family and python
variant('c', default=True,
description="Build support for C-family languages")
+ variant('pic', default=True,
+ description='Build position independent code')
variant('python', default=True,
description="Build support for python")
@@ -63,9 +47,13 @@ class Thrift(Package):
depends_on('zlib', when='+c')
depends_on('libevent', when='+c')
+ def setup_environment(self, spack_env, run_env):
+ if '+pic' in self.spec:
+ spack_env.append_flags('CFLAGS', self.compiler.pic_flag)
+ spack_env.append_flags('CXXFLAGS', self.compiler.pic_flag)
+
def install(self, spec, prefix):
env['PY_PREFIX'] = prefix
- env['JAVA_HOME'] = spec['java'].prefix
# configure options
options = ['--prefix=%s' % prefix]
@@ -73,6 +61,7 @@ class Thrift(Package):
options.append('--with-boost=%s' % spec['boost'].prefix)
options.append('--enable-tests=no')
+ options.append('--with-nodejs=no')
options.append('--with-c=%s' % ('yes' if '+c' in spec else 'no'))
options.append('--with-python=%s' %
('yes' if '+python' in spec else 'no'))