summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/typhonio/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/typhonio/package.py')
-rw-r--r--var/spack/repos/builtin/packages/typhonio/package.py34
1 files changed, 19 insertions, 15 deletions
diff --git a/var/spack/repos/builtin/packages/typhonio/package.py b/var/spack/repos/builtin/packages/typhonio/package.py
index de6897b361..8bfcb29751 100644
--- a/var/spack/repos/builtin/packages/typhonio/package.py
+++ b/var/spack/repos/builtin/packages/typhonio/package.py
@@ -8,23 +8,27 @@ from spack.package import *
class Typhonio(CMakePackage):
"""TyphonIO is a library of routines that perform input/output (I/O)
- of scientific data within application codes"""
+ of scientific data within application codes"""
homepage = "https://uk-mac.github.io/typhonio/"
- url = "https://github.com/UK-MAC/typhonio/archive/v1.6_CMake.tar.gz"
- git = "https://github.com/UK-MAC/typhonio.git"
-
- version('develop', branch='cmake_build')
- version('1.6_CMake', sha256='c9b7b2a7f4fa0b786f6b69c6426b67f42efc4ea6871323139d52cd44f4d0ff7c')
-
- variant('build_type', default='Release', values=('Debug', 'Release'),
- description='The build type to build')
- variant('fortran', default=False, description='Enable Fortran support')
- variant('shared', default=False, description='Build shared libraries')
- variant('doc', default=False, description='Build user guide and doxygen documentation')
-
- depends_on('mpi')
- depends_on('hdf5+hl')
+ url = "https://github.com/UK-MAC/typhonio/archive/v1.6_CMake.tar.gz"
+ git = "https://github.com/UK-MAC/typhonio.git"
+
+ version("develop", branch="cmake_build")
+ version("1.6_CMake", sha256="c9b7b2a7f4fa0b786f6b69c6426b67f42efc4ea6871323139d52cd44f4d0ff7c")
+
+ variant(
+ "build_type",
+ default="Release",
+ values=("Debug", "Release"),
+ description="The build type to build",
+ )
+ variant("fortran", default=False, description="Enable Fortran support")
+ variant("shared", default=False, description="Build shared libraries")
+ variant("doc", default=False, description="Build user guide and doxygen documentation")
+
+ depends_on("mpi")
+ depends_on("hdf5+hl")
def cmake_args(self):
spec = self.spec