summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/umpire/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/umpire/package.py')
-rw-r--r--var/spack/repos/builtin/packages/umpire/package.py43
1 files changed, 43 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/umpire/package.py b/var/spack/repos/builtin/packages/umpire/package.py
new file mode 100644
index 0000000000..d3d31f6cd6
--- /dev/null
+++ b/var/spack/repos/builtin/packages/umpire/package.py
@@ -0,0 +1,43 @@
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+
+from spack import *
+
+
+class Umpire(CMakePackage):
+ """An application-focused API for memory management on NUMA & GPU
+ architectures"""
+
+ homepage = 'https://github.com/LLNL/Umpire'
+ git = 'https://github.com/LLNL/Umpire.git'
+
+ version('develop', branch='develop', submodules='True')
+ version('master', branch='master', submodules='True')
+ version('0.1.4', tag='v0.1.4', submodules='True')
+ version('0.1.3', tag='v0.1.3', submodules='True')
+
+ variant('cuda', default=False, description='Build with CUDA support')
+ variant('fortran', default=False, description='Build C/Fortran API')
+
+ depends_on('cuda', when='+cuda')
+ depends_on('cmake@3.3:', type='build')
+
+ def cmake_args(self):
+ spec = self.spec
+
+ options = []
+
+ if '+cuda' in spec:
+ options.extend([
+ '-DENABLE_CUDA=On',
+ '-DCUDA_TOOLKIT_ROOT_DIR=%s' % (spec['cuda'].prefix)])
+ else:
+ options.append('-DENABLE_CUDA=Off')
+
+ if '+fortran' in spec:
+ options.append('-DENABLE_FORTRAN=On')
+
+ return options