summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/valgrind/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/valgrind/package.py')
-rw-r--r--var/spack/repos/builtin/packages/valgrind/package.py56
1 files changed, 23 insertions, 33 deletions
diff --git a/var/spack/repos/builtin/packages/valgrind/package.py b/var/spack/repos/builtin/packages/valgrind/package.py
index b950e1cffd..3f9b7f39eb 100644
--- a/var/spack/repos/builtin/packages/valgrind/package.py
+++ b/var/spack/repos/builtin/packages/valgrind/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
import sys
@@ -35,22 +16,34 @@ class Valgrind(AutotoolsPackage):
Valgrind is Open Source / Free Software, and is freely available
under the GNU General Public License, version 2.
-
"""
homepage = "http://valgrind.org/"
- url = "http://valgrind.org/downloads/valgrind-3.11.0.tar.bz2"
+ url = "https://sourceware.org/pub/valgrind/valgrind-3.13.0.tar.bz2"
+ git = "git://sourceware.org/git/valgrind.git"
+ version('develop', branch='master')
+ version('3.14.0', '74175426afa280184b62591b58c671b3')
+ version('3.13.0', '817dd08f1e8a66336b9ff206400a5369')
version('3.12.0', '6eb03c0c10ea917013a7622e483d61bb')
version('3.11.0', '4ea62074da73ae82e0162d6550d3f129')
version('3.10.1', '60ddae962bc79e7c95cfc4667245707f')
version('3.10.0', '7c311a72a20388aceced1aa5573ce970')
- version('develop', svn='svn://svn.valgrind.org/valgrind/trunk')
variant('mpi', default=True,
description='Activates MPI support for valgrind')
variant('boost', default=True,
description='Activates boost support for valgrind')
+ variant('only64bit', default=True,
+ description='Sets --enable-only64bit option for valgrind')
+ variant('ubsan', default=True,
+ description='Activates ubsan support for valgrind')
+ conflicts('+ubsan', when='platform=darwin %clang',
+ msg="""
+Cannot build libubsan with clang on macOS.
+Otherwise with (Apple's) clang there is a linker error:
+clang: error: unknown argument: '-static-libubsan'
+""")
depends_on('mpi', when='+mpi')
depends_on('boost', when='+boost')
@@ -65,14 +58,11 @@ class Valgrind(AutotoolsPackage):
def configure_args(self):
spec = self.spec
options = []
- if not (spec.satisfies('%clang') and sys.platform == 'darwin'):
- # Otherwise with (Apple's) clang there is a linker error:
- # clang: error: unknown argument: '-static-libubsan'
+ if spec.satisfies('+ubsan'):
options.append('--enable-ubsan')
+ if spec.satisfies('+only64bit'):
+ options.append('--enable-only64bit')
if sys.platform == 'darwin':
- options.extend([
- '--build=amd64-darwin',
- '--enable-only64bit'
- ])
+ options.append('--build=amd64-darwin')
return options